Debian broke after package upgrade


Yes, it really happened to me. Debian has broke while doing apt -y upgrade The issue occurred in some weird libc dependency problem. Here is an extract of the error message

dpkg: error processing package libglib2.0-0:i386 (--configure):
dependency problems - leaving triggers unprocessed

(...)

No apport report written because MaxReports is reached already
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
libglib2.0-0:i386 depends on libc6 (>= 2.28); however:
Package libc6:i386 is not configured yet.
libglib2.0-0:i386 depends on libmount1 (>= 2.28); however:
Package libmount1:i386 is not configured yet.

Fortunettly there is fairly easy solution for that problem:

sudo dpkg --configure -a
sudo apt -f install

This solves almost all update problems.

,

Dodaj komentarz

Twój adres e-mail nie zostanie opublikowany.